Welcome, Guest

Shop Amazon.com and support the WKC | WKC T-Shirts

Author Topic: Need help - Any ideas out there?  (Read 1649 times)

ramsfan

  • WKC Performer
  • Posts: 2090
Need help - Any ideas out there?
« on: October 22, 2012, 04:13:14 PM »
I recently just bought a brand new 2013 Weber Performer Platinum. I am having a problem with it that I can't figure out. I thought maybe someone might have an idea? Here's the problem: When I open the gas valve and hit the igniter button, the burner inside the grill ignites just fine.

Where the problem occurs is when I close the gas valve to turn the burner off, a flame (about as big as a candle flame) is created at the very end of the burner tube where the gas hose and burner tube connect. Right where that clip is that is suppose to lock the hose inside the burner tube. There are four rectangle shaped holes in the end of burner tube at that connection and a small flame is created there when I close the gas valve. The flame will stay lit for a long time until I have to blow it out like a candle on a birthday cake.

I have called Weber customer service several times and they are completely perplexed, just as I am. Any thoughts? Has anyone else experienced this same problem? Any help would sure be appreciated. Thanks.
This is the original Weber kettle. The most powerful bbq grill in the world and can blow your taste-buds clean off! So, you have to ask yourself one question: "Do you feel hungry? Well, do you punk?"

zavod44

  • WKC Ambassador
  • Posts: 6152
Re: Need help - Any ideas out there?
« Reply #1 on: October 22, 2012, 04:42:24 PM »
I had the exact same problem, I found that even though I turned off the valve I could actually turn it just a tiny bit more and it would go off.  Try cranking the valve just a tiny bit more off...

Brian
Vintage Weber Grill raconteur and bon vivant.....and definitely Sir Agent X

ramsfan

  • WKC Performer
  • Posts: 2090
Re: Need help - Any ideas out there?
« Reply #2 on: October 22, 2012, 06:40:33 PM »
I just tried your suggestion. I cranked that valve shut as tight as I could. It shrunk the flame somewhat, but it was still there. I think you got the right idea though. I think the valve isn't completely shutting even when it's tightened down hard.
This is the original Weber kettle. The most powerful bbq grill in the world and can blow your taste-buds clean off! So, you have to ask yourself one question: "Do you feel hungry? Well, do you punk?"

zavod44

  • WKC Ambassador
  • Posts: 6152
Re: Need help - Any ideas out there?
« Reply #3 on: October 23, 2012, 07:01:43 PM »
Try and tell Weber your valve won't shut off all the way...If it's new it should be warrantied and you should get a new one....

Brian
Vintage Weber Grill raconteur and bon vivant.....and definitely Sir Agent X

ramsfan

  • WKC Performer
  • Posts: 2090
Re: Need help - Any ideas out there?
« Reply #4 on: October 23, 2012, 07:33:13 PM »
Weber already sent me a new valve assembly. The new one is actually worse than the first one I had. I even made a video and sent it to them so they could actually see the problem for themselves. The engineering dept said they had never seen this problem before. They are sending me out a new burner tube assembly. I think the problem is the valve doesn't completely close.
This is the original Weber kettle. The most powerful bbq grill in the world and can blow your taste-buds clean off! So, you have to ask yourself one question: "Do you feel hungry? Well, do you punk?"