Welcome, Guest

Shop Amazon.com and support the WKC | WKC T-Shirts

Author Topic: Fixed my Weber Bug Zapper Electrocuter  (Read 169 times)

Jimpow7

  • Happy Cooker
  • Posts: 4
Fixed my Weber Bug Zapper Electrocuter
« on: April 13, 2019, 05:27:25 PM »
I purchased this unit with a working lamp. Only to have it break on me when I cleaned it. Knowing full well that replacement lamps do not exist. I tracked down some parts (see pictures) GX10Q 4pin base, two self tapping screws and a new black light lamp. I removed the old lamp base clips without cutting the wires. Installed the wires and screwed the new base to the unit. Reassembled the cage, plugged it in and IT WORKS! Now I can't wait for warm weather and bugs.

PotsieWeber

  • WKC Ranger
  • Posts: 1250
Re: Fixed my Weber Bug Zapper Electrocuter
« Reply #1 on: April 13, 2019, 05:38:28 PM »
Nice @Jimpow7.  Which model did you do it to?

I've got both sizes and I've been toying with just removing the whole bug zapping guts & just rewiring it as a normal light.
regards,
Hal

Jimpow7

  • Happy Cooker
  • Posts: 4
Re: Fixed my Weber Bug Zapper Electrocuter
« Reply #2 on: April 13, 2019, 05:45:26 PM »
Mine is model 23520

Mr.CPHo

  • WKC Performer
  • Posts: 2749
Re: Fixed my Weber Bug Zapper Electrocuter
« Reply #3 on: April 13, 2019, 06:23:27 PM »
This is great info!  Thank you in advance.


Sent from my iPhone using Weber Kettle Club

bladz

  • WKC Brave
  • Posts: 442
Re: Fixed my Weber Bug Zapper Electrocuter
« Reply #4 on: April 13, 2019, 07:58:43 PM »
This is great news. I have one waiting for a bulb.


Sent from my iPhone using Weber Kettle Club