Welcome, Guest

Shop Amazon.com and support the WKC | WKC T-Shirts

Author Topic: Fireboard 2 Drive Blank Screen  (Read 352 times)

Chesapeake Weber

  • WKC Brave
  • Posts: 417
Fireboard 2 Drive Blank Screen
« on: May 30, 2022, 07:52:58 AM »
Not sure how many of you use a fireboard but I wanted to share an issue I ran into yesterday.  I hadnít used it for a long while (last summer I think).  I got it all setup for a rib cook and the fan drive and temp probes connected and worked as expected.

Once the Weber got up to temp, I went in to get the ribs and came back out to a blank screen.  Nothing on it.  It would cycle between a bright (backlit) to dim screen.  It kept doing this for over 45 minutes.  Searching online for something similar only gave advice for a hard reset (hold one of the buttons for 15 to 20 seconds), which I tried with no response. 

After a lot of frustration and annoyance, it finally came back online.  What I had noticed was the firmware of the unit had been updated.  Unfortunately, Fireboard does not have any information about this experience happening on their website (at least that I could find). 

So, if you have one of these and this situation happens to you, no need to freak out.  Itís probably just doing a firmware update and it didnít tell you that was going to happen!

BTW, other than this experience, itís a pretty great unit for maintaining temps and being close to a set it and forget it.  Hope this helps somebody.


Sent from my iPhone using Weber Kettle Club